Aide - Recherche - Membres - Calendrier
Version complète : Mission multi sur SH5
Forums Mille-Sabords.com > Mille-Sabords : Simulations de la 2ème Guerre Mondiale > Silent Hunter 5 > Missions SH5 > Editeur de SH5 et création de missions
Sacha
Après avoir édité une mission multi sur SH5, j'ai un souci récurant et cela indépendamment de l'importance ou de la complexité de la mission.
La mission est bien identifiée dans la section "multijoueurs" et se lance normalement. Mais après quelques minutes elle se stop comme si cette dernière était terminée et je me retrouve sur le tableau des destructions réalisées.
J'ai beau changer les années et contrôler que chaque bâtiment est bien existant à cette période et durant la validité de la durée de la mission. Je fais évidemment les Maps Zone, les Triggers, les Events, le Briefing, le Title et la test avant le lancement. Aucun problème n'est identifié!

Quelqu'un connait il le problème, merci
U768
J’ai eu ce souci en créant mes premières missions.
Seulement, je ne me rappelle plus du tout comment je l’avais résolu, car depuis, j’ai un peu délaissé ce jeu. Tu vas trouver, ce n’était pas très compliqué.

Max
Sacha
tanks
Gibus
Une piste à suggérer :

On a le même problème sur SH4 lorsque les unités ennemies sont situées au-delà de la portée des senseurs du sous-marin.

Si je souhaite, pour des raisons tactiques, conserver cette distance, pour contourner cette difficulté j'implante un ou deux bâtiments ennemis inoffensifs (bateau de pêche, jonque, etc ...) à portée visuelle des soums.
De cette façon, la partie ne se ferme pas sans qu'on ait pu jouer.
Sacha
Merci pour l'indication, mais malheureusement cela ne change pas le problème!
sad.gif
Gibus
Désolé, je n'ai pas d'autres pistes et pas le jeu.
Pkzm
Bonjour à tous,

j'ai exactement le même problème ; la partie démarre, bizarrement dans le jeu ou il y a les événements textes messages <vous arrivez à votre point de destination> puis une minute plus tard fin de partie question.gif

Citation
[Mission]
IsVisible=true
MissionType=1
MissionDataType=0
MultiMissionType=0
IsTutorial=false
Year=1940
Month=1
Day=1
Hour=7
Minute=0
CurrentYear=1940
CurrentMonth=1
CurrentDay=1
CurrentHour=7
CurrentMinute=0
GroupMissionStartDelay=0
IconIndex=0
Fog=0
FogRand=0
Clouds=0
CloudsRand=0
Precip=0
PrecipRand=0
WindHeading=0
WindSpeed=5.000000
WindRand=0
WeatherRndInterval=5
SeaType=0
ActivationAchievements=



Apparemment sur Subsim il dise qu'il faut cocher joueur a porté visuel de l'ennemi !!


arobase.gif ++
Guepard

salut j'avais avec sacha editer des missions sur sh5 au debut et l'on etait que 2 à vouloir lancer le multi en 2010. pour cette histoire avec la mission qui s'arrete au bout de quelques secondes, on a pas mal galerer trouver la soluce ily a cette histoire de date et je me souviens qu'il y avait un truc au niveau des objectifs et du tonnage à indiquer pour valider cet objectif il fallait que le tonnage soit logique par rapport aux unites que l'on inserait dans la mission
si cela peut vous aider chris.gif
fredl109
Bonjour à tous, tout d'abord je vous dirais de vérifier les dates et heures dans le fichier portant l'extension.mis de votre mission, celle ci comporte deux paragraphes portant date et heure de la mission, celle ci doivent être impérativement les même, ensuite votre mission doit comporter des objectifs , sinon comme dans votre cas celle ci s'arrête au bout de quelques minutes, un petit conseil donnez lui un maximum de tonage a couler, vous n'aurez pas de mission qui s'arrête alors qu'il reste des unités a couler, vous pouvez mettre le tonnage maximum même si le total de vos unités ne l'atteint pas, cela ne pose pas de problèmes. voila j'espère que vos soucis seront ainsi résolus.
Amitiés Fred biggrin.gif biggrin.gif biggrin.gif
Pkzm
Bonjour à tous,

Merci de vos conseils mais j'ai tout essayé et rien n'a faire ça veut pas !

Désinstalle et réinstallation du jeu
j'ai comparé mon fichier par rapport à un fichier multi existant du jeu , j'ai même fait un copier coller de la partie objectif triger etc ,,,,, niet !

Conclusion terminé pour moi SH5 crying.gif

arobase.gif +
Cerumno
Citation (Pkzm @ vendredi 20 avril 2012 à 18:59) *
...
Conclusion terminé pour moi SH5 crying.gif
...

Arh, il y a toujours une solution à tout...
Guepard
salut à mon humble avis la reinstallation du jeu ne changeras pas grand chose , tu dois surement louper un truc au niveau de l'editeur regarde bien tes objectifs , dates, tonnages , et tes triggers avec sacha on a galerer un moment avant de trouver je n'ai pas le temps de me remettre dans cette simulation mais si tu veux on se programme rendez vous sur ts et on travaille le truc ensemble chris.gif
Pkzm
Bonjour à tous,

Apparemment ca fonctionne difficile de dire pourquoi, j’édite sur un projet existant dans campaigns et j’ai rempli tout les champs dans la mission.

merci à tous.
Huberik
Bonjour,

Je m'essaye à la creation de mission pour d'eventuel multi, et j'ai le même souci.

La mission debute et au bout d'un temp tres cour (environ 1 min ), panneau de fin de mission.

Quand tu dis que tu edites sur un projet existant ? tu fais quoi exactement je comprend pas trés bien merci.
Pkzm
Citation (Huberik @ lundi 25 juin 2012 à 18:15) *
Bonjour,

Je m'essaye à la creation de mission pour d'eventuel multi, et j'ai le même souci.

La mission debute et au bout d'un temp tres cour (environ 1 min ), panneau de fin de mission.

Quand tu dis que tu edites sur un projet existant ? tu fais quoi exactement je comprend pas trés bien merci.


Bonjour,


Apparemment Cerumno a trouvé d’où venait le problème question.gif je pense s'il passe par ici il va nous le transcrire rolleyes.gif

arobase.gif +
Huberik
ok merci bien.

Bon je ne sais pas comment j 'ai fait mais ça à l'air de fonctionner, je retourne essayer pour pofiner les choses et si ça vous tente de l'essayer pas de souci.
Cerumno
Tu as du mettre une date pour ta mission, 14 juillet 1943 par exemple dans "Start date" que tu retrouve dans "Missions/parametters".

La tu dois y mettre une "Start Time" avec une heure et minute.
Une fois fait tu reprends les heures minutes et tu les inscrits dans "GameEntryTime", exemple 12heures 00 : 1200
Attention à la date, tu pourras même faire apparaître des unités à des heures futures.

Sous marins et bâtiments.
fredl109
Bonjour à tous, Messieurs et je m'adresse a tout ceux qui voudraient se lancer dans la création de missions dans SHV d'abords pour leur dire que c'est sympa de leur part de nous rejoindre dans cet aspect la du jeu mais surtout pour leur dire qu'il faut éviter deux pièges récurant à l'éditeur de SHV qui sont :

1er Lorsque vous créez une mission pour SHV et que vous l'enregistrez, vous devez impérativement aller dans le fichier portant l'extension .mis et vous l'ouvrez avec le bloc note, vous verrez que dans les premières ligne du fichier celui ci comporte des dates et des heures ce sont celles de votre mission et doivent être impérativement les mêmes , donc il vous faudra les modifier en conséquence sous peines d'avoir quelque désagréments lors du lancement de celle ci.

2éme Ce même fichier qui porte l'extension .mis doit être une fois la manipulation faite plus haut renommé avec l'extension ge a la fin c'est à dire .misge sinon gare au surprise lors du lancement de la partie.

Et pour compléter ce que dit notre ami cerumno, je rajouterais que c'est primordial de vérifier les dates de toute vos unités car la aussi cela vous évitera de grosses mauvaises surprises, de plus penser à bien mettre "Deletonlastwaypoint" sur "False" cela vous évitera aussi quelque désagréments.

Voili Voila, en espérant vous avoir été utile.

Amitiés Fred biggrin.gif biggrin.gif biggrin.gif biggrin.gif
Huberik
Merci Mr.

sinon "Deletonlastwaypoint" sur "False" ou et à quel moment ?
fredl109
Bonjour huberik, lorsque tu construit une mission, et lorsque tu ajoutes des unités ennemies, tu verras que au bas du panneau de configuration de l'unité tu as "deleteonlastwaypoint" portant la mention "True" il faut la passer sur "False" par le menu déroulant adjoint.
Amitiés Fred biggrin.gif biggrin.gif biggrin.gif
Cerumno
Citation (Huberik @ mardi 26 juin 2012 à 12:42) *
Merci Mr.

sinon "Deletonlastwaypoint" sur "False" ou et à quel moment ?


Personnellement je ne touche pas ce paramètre qui ce trouve sous la date d'entrée de chaque bâtiments.
cela ma valu de déconnexion au bou d'une minute.
fredl109
Bonjour mon ami, curieusement, c'est tout le contraire qui doit se produire, en effet si tu ne fait pas cela, tes unités disparaissent au bout de leur dernier waypoint et la tu risque de te retrouver avec une partie fini avant de commencer.
Amitiés Fred biggrin.gif biggrin.gif biggrin.gif
Cerumno
Citation (fredl109 @ mardi 26 juin 2012 à 13:26) *
Bonjour mon ami, curieusement, c'est tout le contraire qui doit se produire, en effet si tu ne fait pas cela, tes unités disparaissent au bout de leur dernier waypoint et la tu risque de te retrouver avec une partie fini avant de commencer.
Amitiés Fred biggrin.gif biggrin.gif biggrin.gif

question.gif je referai des tests demain soir... ^^
fredl109
Re, il faudrait que tout les deux on fasse la manip ensemble en créant une simple petite mission test, pour voir justement les réaction d'un coté et de l'autre, je pense que cela serait très instructif et nous permettrait de voir ou sont les problèmes,contacte moi pour voir si on pourrait pas se joindre a une heure qui te convient, de préférence vers les 21 h si cela ne te dérange pas.
Amitiés Fred biggrin.gif biggrin.gif biggrin.gif
Huberik
Ayant essayé deja 2 missions, j'ai mis le way point tres loin, donc pas de risque que le convoi y arrive ou alors les U boot non pas fait leurs boulots ^^
Ceci est une version "bas débit" de notre forum. Pour voir la version complète avec plus d'informations, la mise en page et les images, veuillez cliquer ici.
Invision Power Board © 2001-2020 Invision Power Services, Inc.